分享个Mikrotik routeros的花生壳DDNS动态域名解析脚本
in 默认/网络 1 条评论and 阅读数:1812

分享个Mikrotik routeros的花生壳DDNS动态域名解析脚本

in 默认网络 1 条评论and 阅读数:1813

简介

弄了路由器用来搭建自己的ipsec组网,因为拨号获取的是动态的公网ip地址,需要用ddns来解析地址,这样方便使用,花生壳官网提供的脚本解析不出来。


脚本内容

需要修改需要解析的域名、花生壳账号、密码,获取公网地址的接口

local server "http://ddns.oray.com"
local domain "xxx.top"   #花生壳域名
local users "oray username"  #花生壳账号
local paswd "oray userpaswd" #花生壳密码
local adslinterface "pppoe-outx"   #解析地址的网络接口,pppoe拨号或者动态地址公网的
local ipaddr
:global lastipaddr

set ipaddr [/ip address get [/ip address find interface=$adslinterface] address]
:if ([ :typeof $ipaddr ] = nil ) do={
   :log info ("ORAY: No ip address present on " . $adslinterface . ", please check.")
} else={
   set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
   :log info $ipaddr
   :if ($ipaddr != $lastipaddr) do={
    local par "/ph/update?&hostname=$domain&myip=$ipaddr"
    :log info "ORAY: Sending UPDATE!"
    :log info [:put [ /tool fetch url=($server . $par) mode=http user=$users password=$paswd ] ]
    :global lastipaddr $ipaddr

  } else={
    :log info "ORAY: No update required."
  }
}
  1. kxqing

    你好,不能用,可以帮忙解决一些问题吗?

    回复
文章状态:已收录~